Cisco3745 初期状態の設定について

シェアする

最近、GNS3を利用して、Cisco IOSの設定パラメータまわりを中心に、久々に弄ってみようと思いました。
GNS3の使い方は、ここでは割愛しています。

モデルは、依然に少しだけ見たこと(触ったことはない)がある、Cisco 3745です。

初期状態のパラメータについて(startup-config)

GNS3でCisco 3745のテンプレートを作成し起動した状態の表示されるパラメータです。

R1# terminal length 0          <= 表示される内容を途中で止めない
R1# show startup-config
Using 402 out of 155640 bytes! <= 155640バイトのうち402バイトを使用
!
service timestamps debug datetime msec <= デバッグ出力時のタイムスタンプ設定
service timestamps log datetime msec   <=ログ出力時のタイムスタンプ設定
no service password-encryption         <= パスワード暗号化の設定(しない)
!
hostname R1                            <= ホスト名の設定
!
ip cef                            <= スイッチング方式の設定[Cisco Express Forwarding]
no ip domain-lookup               <= 名前解決を有効に設定(しない)
no ip icmp rate-limit unreachable <= ICMPエラー送信間隔の設定(しない)
ip tcp synwait 5                  <= TCP接続試行時間の設定[単位:秒]
no cdp log mismatch duplex        <= CDPが検出したデュプレックスミスマッチをログ出力する設定(しない)
!
line con 0 <= コンソールポートに関する設定[CON]
 exec-timeout 0 0    <= EXECモードからのタイムアウト(ログアウトしない)
 logging synchronous <= コマンド入力途中にログ出力で分断するのを抑止する設定
 privilege level 15  <= レベル15[特権モード]で接続する設定
 no login            <= ログイン要求をする設定(しない)
line aux 0 <= アクセサリーポートに関する設定[AUX]
 exec-timeout 0 0
 logging synchronous
 privilege level 15
 no login
!
!
end <= 特権モードに戻る設定

上記が、GNS3での「startup-config」の設定されている内容でしたが、定義をおこなうには「running-config」上で設定を行ないます。

初期状態のパラメータについて(running-config)

下記が、出力されたrunning-configのパラメータです。
ハードウェアのインタフェースなどが表示されています。

R1# show running-config
Building configuration...  <= ビルドの実行中
Current configuration : 2024 bytes
!
version 12.4                           <= CiscoIOSのバージョン(12.4)
service timestamps debug datetime msec <= デバッグ出力時のタイムスタンプ設定
service timestamps log datetime msec   <= ログ出力時のタイムスタンプ設定
no service password-encryption         <= パスワード暗号化の設定(しない)
!
hostname R1                            <= ホスト名の設定(R1)
!
boot-start-marker <= 表示されるだけで変更できない(bootコマンドの始まり)
boot-end-marker   <= 表示されるだけで変更できない(bootコマンドの終わり)
!
!
no aaa new-model                  <= AAA認証の設定(しない)(RADIUS,TACACS+)
memory-size iomem 5               <= I/Oメモリーへの割り当て割合
no ip icmp rate-limit unreachable <= ICMPエラー送信間隔の設定(しない)
ip cef           <= スイッチング方式の設定[Cisco Express Forwarding]
!
!
!
!
no ip domain lookup              <= 名前解決を有効に設定(しない)
ip auth-proxy max-nodata-conns 3 <= 認証プロキシーでアイドル状態の最大接続数
ip admission max-nodata-conns 3  <= AAAサーバーに到達できないアイドル状態の最大接続数
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5 <= TCP接続試行時間の設定[単位:秒]
!
!
!
!
!
interface FastEthernet0/0  <= インターフェースに関する設定(イーサネット)
no ip address  <= IPアドレス設定なし
shutdown  <= 停止状態
duplex auto  <= 通信モード自動
speed auto  <= 通信速度モード自動
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
!
interface FastEthernet1/1
!
interface FastEthernet1/2
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
 no ip address
!
ip forward-protocol nd  <= SUN-ND(Network Disk)のルータ越え設定
!
!
no ip http server  <= Webベース管理時のHTTPサーバ有効の設定(しない)
no ip http secure-server  <= Webベース管理時のHTTPSサーバ有効の設定(しない)
!
no cdp log mismatch duplex
!
!
!
control-plane  <= コントロールプレーンの利用(何も設定されていない)
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4  <= 仮想ポートに関する設定(0~4なので5個)
login  <= ログイン要求をする設定
!
!
end