Cisco3745 VLANでネットワーク構築

シェアする

GNS3を使って、VLAN構成で簡単なネットワークを構築します。なお、現在、推奨されていない「vlan database」での構築となります。

ネットワーク構成

この記事では、下記の図にある「R1」の設定を行なうことにします。

VPCS側に接続されるネットワークをVLANにて、それぞれ、192.168.10.0/24から192.168.30.0/24とし、R2側に接続されるネットワークをVLANにて、192.168.100.0/24とします。

基本的な設定

設定する内容は、下記の通り。

・ホスト名の設定
・パスワードの設定(コンソールポート接続時のパスワードと特権EXECモードのパスワード)
・インターフェースの有効化とIPアドレス設定

R1#configure terminal                    <= コンフィグモード
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#no logging console            <= コンソールにログを出さない
R1(config)#hostname c3745                <= ホスト名を「c3745」にする
c3745(config)#line console 0             <= コンソールポートに関する設定
c3745(config-line)#password consolepass  <= コンソールポート接続時パスワード 
c3745(config-line)#login                 <= ログイン要求をする
c3745(config-line)#exit
c3745(config)#service password-encryption <= パスワードは暗号化
c3745(config)#enable secret enablepass   <= 特権EXECモード移行時のパスワード
c3745(config)#exit
c3745#exit                   <= 設定したパスワードに間違いがないかを確認するため

c3745 con0 is now available

Press RETURN to get started.

User Access Verification
Password:consolepass <= コンソールポート接続時のパスワード
c3745>enable
Password:enablepass  <= 特権EXECのパスワード
c3745#write memory   <= パスワードに問題なければ不揮発メモリーに書き込む
Building configuration...
[OK]
c3745#erase flash:
Erasing the flash filesystem will remove all files! Continue? [confirm] <= [Enter]キー押下
Current DOS File System flash card in flash:
 will be formatted into Low End File System flash card! Continue? [confirm] <= [Enter]キー押下
Erasing device... eeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeeee ...erased
Erase of flash: complete
c3745#vlan database
c3745(vlan)#vlan 10
VLAN 10 added:
     Name: VLAN0010
c3745(vlan)#vlan 20
VLAN 20 added:
     Name: VLAN0020
c3745(vlan)#vlan 30
VLAN 30 added:
     Name: VLAN0030
c3745(vlan)#exit
APPLY completed.
Exiting....
c3745#show vlan-switch

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/0, Fa1/1, Fa1/2, Fa1/3
                                                Fa1/4, Fa1/5, Fa1/6, Fa1/7
                                                Fa1/8, Fa1/9, Fa1/10, Fa1/11
                                                Fa1/12, Fa1/13, Fa1/14, Fa1/15
10   VLAN0010                         active
20   VLAN0020                         active
30   VLAN0030                         active
1002 fddi-default                     active
1003 token-ring-default               active
1004 fddinet-default                  active
1005 trnet-default                    active

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        1002   1003
10   enet  100010     1500  -      -      -        -    -        0      0
20   enet  100020     1500  -      -      -        -    -        0      0
30   enet  100030     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        1      1003
1003 tr    101003     1500  1005   0      -        -    srb      1      1002
1004 fdnet 101004     1500  -      -      1        ibm  -        0      0
1005 trnet 101005     1500  -      -      1        ibm  -        0      0
c3745#conf t
Enter configuration commands, one per line. End with CNTL/Z.
c3745(config)#int fa1/0
c3745(config-if)#switchport mode access
c3745(config-if)#switchport access vlan 10
c3745(config-if)#end
c3745#conf t
Enter configuration commands, one per line. End with CNTL/Z.
c3745(config)#int fa1/1
c3745(config-if)#switchport mode access
c3745(config-if)#switchport access vlan 20
c3745(config-if)#end
c3745#conf t
Enter configuration commands, one per line. End with CNTL/Z.
c3745(config)#int fa1/2
c3745(config-if)#switchport mode access
c3745(config-if)#switchport access vlan 30
c3745(config-if)#end
c3745#conf t
Enter configuration commands, one per line. End with CNTL/Z.
c3745(config)#interface vlan 10
c3745(config-if)#ip address 192.168.10.1 255.255.255.0
c3745(config-if)#no shutdown
c3745(config-if)#exit
c3745(config)#interface vlan 20
c3745(config-if)#ip address 192.168.20.1 255.255.255.0
c3745(config-if)#no shutdown
c3745(config-if)#exit
c3745(config)#interface vlan 30
c3745(config-if)#ip address 192.168.30.1 255.255.255.0
c3745(config-if)#no shutdown
c3745(config-if)#exit
c3745(config)#exit
c3745#sh run <= ここまで設定した内容確認
Building configuration...
 
Current configuration : 1734 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname c3745
!
boot-start-marker
boot-end-marker
!
no logging console
enable secret 5 $1$dwLM$BfRt2uBTxhS.IxVrq31WP.
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet1/0
  switchport access vlan 10
!
interface FastEthernet1/1
  switchport access vlan 20
!
interface FastEthernet1/2
  switchport access vlan 30
!
interface FastEthernet1/3
!
interface FastEthernet1/4
!
interface FastEthernet1/5
!
interface FastEthernet1/6
!
interface FastEthernet1/7
!
interface FastEthernet1/8
!
interface FastEthernet1/9
!
interface FastEthernet1/10
!
interface FastEthernet1/11
!
interface FastEthernet1/12
!
interface FastEthernet1/13
!
interface FastEthernet1/14
!
interface FastEthernet1/15
!
interface Vlan1
no ip address
!
interface Vlan10
  ip address 192.168.10.1 255.255.255.0
!
interface Vlan20
  ip address 192.168.20.1 255.255.255.0
!
interface Vlan30
  ip address 192.168.30.1 255.255.255.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
exec-timeout 0 0
privilege level 15
password 7 0307540515002D495E080A16
logging synchronous
login
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
line vty 0 4
login
!
!
end
 
c3745#write memory
Building configuration...
[OK]
#vlan database
#vlan 100
VLAN 100 added:
     Name: VLAN0100
c3745(vlan)#exit
APPLY completed.
Exiting....
c3745#conf t
Enter configuration commands, one per line. End with CNTL/Z.
c3745(config)#int fa1/10
c3745(config-if)#switchport mode access
c3745(config-if)#switchport access vlan 100
c3745(config-if)#end
c3745#conf t
Enter configuration commands, one per line. End with CNTL/Z.
c3745(config)#int vlan 100
c3745(config-if)#ip address 192.168.100.10 255.255.255.0
c3745(config-if)#no shutdown
c3745(config-if)#exit
c3745(config)#exit
c3745#