GNS3でCisco3745をエミュレーション

シェアする

GNS3を使ってCisco3745をエミュレーションしてみました。これを使うことで、基本的なネットワークの勉強が出来そうです。

Cisco3745について

どんな機器だったのかを簡単に調べてみました。

発売されたのは、2002年。新たなラインナップとして「Cisco3700シリーズ」が追加され、その一つがCisco3745という機器です。

当時の大容量化していくネットワーク環境を、縁の下で支えてきた機器だと思います。

GNS3でのネットワーク構成

GNS3では、下記のように、GUI上でネットワークの構成を組むことができます。

初期パラメータ(startup-config)

startup-configとは、起動したタイミングで、設定内容が読み込まれるコンフィグレーションファイルで、不揮発メモリーに保存されるため、電源OFFで設定が消えることはありません。

Cisco3745#terminal length 0 <= 表示される内容を途中で止めない
Cisco3745#show startup-config <= 不揮発メモリーにある定義を参照
Using 436 out of 155640 bytes! <= 155640バイトのうち402バイトを使用
!
service timestamps debug datetime msec <= デバッグ出力時のタイムスタンプ設定
service timestamps log datetime msec   <=ログ出力時のタイムスタンプ設定
no service password-encryption         <= パスワード暗号化の設定(しない)
!
hostname Cisco3745 <= ホスト名の設定
!
ip cef <= スイッチング方式の設定[Cisco Express Forwarding]
no ip domain-lookup <= 名前解決を有効に設定(しない)
no ip icmp rate-limit unreachable <= ICMPエラー送信間隔の設定(しない)
ip tcp synwait 5 <= TCP接続試行時間の設定[単位:秒]
no cdp log mismatch duplex <= CDPが検出したデュプレックスミスマッチをログ出力する設定(しない)
!
line con 0 <= コンソールポートに関する設定[CON]
 exec-timeout 0 0    <= EXECモードからのタイムアウト(ログアウトしない)
 logging synchronous <= コマンド入力途中にログ出力で分断するのを抑止する設定
 privilege level 15  <= レベル15[特権モード]で接続する設定
 no login            <= ログイン要求をする設定(しない)
line aux 0 <= アクセサリーポートに関する設定[AUX]
 exec-timeout 0 0
 logging synchronous
 privilege level 15
 no login
!
!
end <= 特権モードに戻る設定

初期パラメータ(running-config)

running-configは、動作中に使用するコンフィグレーションファイルで、設定した定義は、即反映されます。揮発性メモリーに書き込まれるため、電源OFFを行なうと設定した定義は消えてしまいます。

Cisco3745#show running-config
Building configuration...   <= ビルドの実行中

Current configuration : 1201 bytes
!
version 12.4                           <= CiscoIOSのバージョン(12.4)
service timestamps debug datetime msec <= デバッグ出力時のタイムスタンプ設定
service timestamps log datetime msec   <= ログ出力時のタイムスタンプ設定
no service password-encryption         <= パスワード暗号化の設定(しない)
!
hostname Cisco3745 <= ホスト名の設定
!
boot-start-marker <= 表示されるだけで変更できない(bootコマンドの始まり)
boot-end-marker   <= 表示されるだけで変更できない(bootコマンドの終わり)
!
!
no aaa new-model                  <= AAA認証の設定(しない)(RADIUS,TACACS+)
memory-size iomem 5               <= I/Oメモリーへの割り当て割合
no ip icmp rate-limit unreachable <= ICMPエラー送信間隔の設定(しない)
ip cef
!
!
!
!
no ip domain lookup              <= 名前解決を有効に設定(しない)
ip auth-proxy max-nodata-conns 3 <= 認証プロキシーでアイドル状態の最大接続数
ip admission max-nodata-conns 3  <= AAAサーバーに到達できないアイドル状態の最大接続数
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip tcp synwait-time 5 <= TCP接続試行時間の設定[単位:秒]
!
!
!
!
!
interface FastEthernet0/0 <= インターフェースに関する設定
 no ip address <= IPアドレス設定なし
 shutdown      <= 停止状態
 duplex auto   <= 通信モード自動
 speed auto    <= 通信速度モード自動
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet3/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
interface FastEthernet4/0
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip forward-protocol nd <= SUN-ND(Network Disk)のルータ越え設定
!
!
no ip http server        <= Webベース管理時のHTTPサーバ有効の設定(しない)
no ip http secure-server <= Webベース管理時のHTTPSサーバ有効の設定(しない)
!
no cdp log mismatch duplex
!
!
!
control-plane <= コントロールプレーンの利用(何も設定されていない)
!
!
!
!
!
!
!
!
!
!
line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4 <= 仮想ポートに関する設定(0~4なので5個)
 login <= ログイン要求をする設定
!
!
end

Cisco3745#write memory <= 不揮発メモリー(NVRAM)への書き込み
Building configuration...
[OK]