Cisco Catalyst3750 v2の初期定義

シェアする

今まで、ネットワーク機器などの専用機は、買わないようにしようと思っていましたが、先日、ついつい買ってしまいました。

買ったのは「Cisco Catalyst 3750 v2」です。。。

機器の構成を簡単に紹介すれば、下記の通り。

Cisco Catalyst 3750-24TS
イーサネット 10/100 ポート× 24
Small Form-factor Pluggable(SFP)ポート× 2

今後は、ネットワークに関することは、上記の機器が中心になるかと思います。

初期起動時の定義

電源投入後に、揮発メモリーに表示される定義です。

   :(省略)
--- System Configuration Dialog ---

Enable secret warning
----------------------------------
In order to access the device manager, an enable secret is required
If you enter the initial configuration dialog, you will be prompted for the enable secret
If you choose not to enter the intial configuration dialog, or if you exit setup without setting the enable secret,
please set an enable secret using the following CLI in configuration mode-
enable secret 0 <cleartext password>
----------------------------------
Would you like to enter the initial configuration dialog? [yes/no]: no
Switch>enable
Switch#show startup-config
startup-config is not present
Switch#show running-config
Building configuration...

Current configuration : 1443 bytes
!
version 12.2
no service pad <= PAD(Packet Assembly and Disassembly)サービスの無効化
service timestamps debug datetime msec <= デバッグ出力時のタイムスタンプ設定
service timestamps log datetime msec   <= ログ出力時のタイムスタンプ設定
no service password-encryption         <= パスワード暗号化の無効化
!
hostname Switch <= ホスト名の設定
!
boot-start-marker <= bootコマンドの始まり(無効に出来ない)
boot-end-marker   <= bootコマンドの終わり(無効に出来ない)
!
!
!
!
no aaa new-model <= AAA認証の無効化
switch 1 provision ws-c3750v2-24ts <= スタックのオフライン設定
system mtu routing 1500 <= ルーテッドポート用MTU値の設定
authentication mac-move permit <= MAC移動の有効化
ip subnet-zero <= ゼロサブネットの有効化
!
!
!
!
!
!
!
!
spanning-tree mode pvst <= スパニングツリーのモード設定
spanning-tree etherchannel guard misconfig <= EtherChannel設定の矛盾を検出する設定
spanning-tree extend system-id <= 拡張システムID機能の有効化
!
vlan internal allocation policy ascending <= 内部VLAN割り当て方法の設定
!
!
!
!
interface FastEthernet1/0/1
!
interface FastEthernet1/0/2
!
interface FastEthernet1/0/3
!
interface FastEthernet1/0/4
!
interface FastEthernet1/0/5
!
interface FastEthernet1/0/6
!
interface FastEthernet1/0/7
!
interface FastEthernet1/0/8
!
interface FastEthernet1/0/9
!
interface FastEthernet1/0/10
!
interface FastEthernet1/0/11
!
interface FastEthernet1/0/12
!
interface FastEthernet1/0/13
!
interface FastEthernet1/0/14
!
interface FastEthernet1/0/15
!
interface FastEthernet1/0/16
!
interface FastEthernet1/0/17
!
interface FastEthernet1/0/18
!
interface FastEthernet1/0/19
!
interface FastEthernet1/0/20
!
interface FastEthernet1/0/21
!
interface FastEthernet1/0/22
!
interface FastEthernet1/0/23
!
interface FastEthernet1/0/24
!
interface GigabitEthernet1/0/1
!
interface GigabitEthernet1/0/2
!
interface Vlan1
no ip address
!
ip classless <= クラスレスの有効化
ip http server <= スイッチ上でhttpサービスを有効化
ip http secure-server <= スイッチ上でhttpsサービスを有効化
!
!
ip sla enable reaction-alerts <= パフォーマンス測定の設定
!
!
!
line con 0
line vty 5 15
!
end

初期起動後の状態で、イマイチ良く分からない定義もあったりして、今後、整理していこうと思います。

初期起動時のデフォルト

デフォルトの定義を表示させると、見たこともない定義があったりします。

Switch#show running-config all
Building configuration...

Current configuration with default configurations exposed : 19387 bytes
!
version 12.2
parser cache
no service log backtrace
no service config
no service exec-callback
no service nagle
service slave-log
no service slave-coredump
no service pad to-xot
no service pad from-xot
no service pad cmns
no service pad
no service telnet-zeroidle
no service tcp-keepalives-in
no service tcp-keepalives-out
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
no service exec-wait
no service linenumber
no service internal
no service scripting
no service compress-config
service prompt config
no service old-slip-prompts
no service pt-vty-logging
no service disable-ip-fast-frag
no service sequence-numbers
service counters max age 0
!
hostname Switch
!
boot-start-marker
boot-end-marker
!
shell processing
no logging discriminator
logging exception 4096
no logging count
no logging message-counter log
no logging message-counter debug
logging message-counter syslog
no logging snmp-authfail
logging buginf
logging queue-limit 100
logging queue-limit esm 0
logging queue-limit trap 100
logging buffered 4096 debugging
logging reload message-limit 1000 notifications
logging console debugging
logging monitor debugging
logging on
!
!
!
no aaa new-model
switch 1 provision ws-c3750v2-24ts
system mtu routing 1500
no cisp enable
authentication mac-move permit
authentication command bounce-port ignore
authentication command disable-port ignore
authentication critical recovery delay 100
no mab request format attribute 32
nmsp notification interval attachment 30
nmsp notification interval location 30
ip subnet-zero
ip sticky-arp
!
!
no ip dhcp snooping information option allow-untrusted
ip dhcp snooping information option
no ip dhcp snooping database
ip dhcp snooping database write-delay 300
ip dhcp snooping database timeout 300
ip dhcp snooping verify mac-address
ip dhcp snooping verify no-relay-agent-address
ip device tracking probe count 3
ip device tracking probe interval 30
no ip device tracking
ip arp inspection log-buffer entries 32
ip arp inspection log-buffer logs 5 interval 1
ip igmp snooping report-suppression
no ip igmp snooping tcn query solicit
ip igmp snooping tcn flood query count 2
ip igmp snooping robustness-variable 2
ip igmp snooping last-member-query-count 2
ip igmp snooping last-member-query-interval 1000
ip igmp snooping querier version 2
ip igmp snooping querier query-interval 60
ip igmp snooping querier max-response-time 10
ip igmp snooping querier timer expiry 0
ip igmp snooping querier tcn query count 2
ip igmp snooping querier tcn query interval 10
no ip igmp snooping querier
ip igmp snooping vlan 1
ip igmp snooping vlan 1 mrouter learn pim-dvmrp
no ip igmp snooping vlan 1 immediate-leave
ip igmp snooping vlan 1 robustness-variable 0
ip igmp snooping vlan 1 last-member-query-count 0
ip igmp snooping vlan 1 last-member-query-interval 0
ip igmp snooping
cluster run
!
vmps reconfirm 60
vmps retry 3
mls qos rewrite ip dscp
mvr vlan 1
mvr querytime 5
mvr mode compatible
scripting tcl low-memory 10774661
!
!
power inline consumption default 15400
dot1x system-auth-control
dot1x supplicant force-multicast
no dot1x critical eapol
!
!
!
port-channel load-balance src-mac
spanning-tree mode pvst
no spanning-tree dispute
spanning-tree transmit hold-count 6
spanning-tree optimize bpdu transmission
spanning-tree queue maxsize 12288
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
spanning-tree uplinkfast max-update-rate 87869952
spanning-tree pathcost method short
!
!
vlan internal allocation policy ascending
!
!
!
!
interface FastEthernet1/0/1
switchport
switchport access vlan 1
switchport trunk encapsulation negotiate
no switchport nonegotiate
no switchport protected
no switchport block multicast
no switchport block unicast
no ip arp inspection trust
ip arp inspection limit rate 15 burst interval 1
ip arp inspection limit rate 15
no shutdown
snmp trap mac-notification change added
snmp trap mac-notification change removed
snmp trap link-status
spanning-tree port-priority 3
spanning-tree cost 3
ip igmp snooping tcn flood
!
interface FastEthernet1/0/2
switchport
switchport access vlan 1
switchport trunk encapsulation negotiate
no switchport nonegotiate
no switchport protected
no switchport block multicast
no switchport block unicast
no ip arp inspection trust
ip arp inspection limit rate 15 burst interval 1
ip arp inspection limit rate 15
no shutdown
snmp trap mac-notification change added
snmp trap mac-notification change removed
snmp trap link-status
spanning-tree port-priority 3
spanning-tree cost 3
ip igmp snooping tcn flood
!
interface FastEthernet1/0/3
switchport
switchport access vlan 1
switchport trunk encapsulation negotiate
no switchport nonegotiate
no switchport protected
no switchport block multicast
no switchport block unicast
no ip arp inspection trust
ip arp inspection limit rate 15 burst interval 1
ip arp inspection limit rate 15
no shutdown
snmp trap mac-notification change added
snmp trap mac-notification change removed
snmp trap link-status
spanning-tree port-priority 3
spanning-tree cost 3
ip igmp snooping tcn flood
!
interface FastEthernet1/0/4
switchport
switchport access vlan 1
switchport trunk encapsulation negotiate
no switchport nonegotiate
no switchport protected
no switchport block multicast
no switchport block unicast
no ip arp inspection trust
ip arp inspection limit rate 15 burst interval 1
ip arp inspection limit rate 15
no shutdown
snmp trap mac-notification change added
snmp trap mac-notification change removed
snmp trap link-status
spanning-tree port-priority 3
spanning-tree cost 3
ip igmp snooping tcn flood
!
interface FastEthernet1/0/5
switchport
switchport access vlan 1
switchport trunk encapsulation negotiate
no switchport nonegotiate
no switchport protected
no switchport block multicast
no switchport block unicast
no ip arp inspection trust
ip arp inspection limit rate 15 burst interval 1
ip arp inspection limit rate 15
no shutdown
snmp trap mac-notification change added
snmp trap mac-notification change removed
snmp trap link-status
spanning-tree port-priority 3
spanning-tree cost 3
ip igmp snooping tcn flood
!
interface FastEthernet1/0/6
switchport
switchport access vlan 1
switchport trunk encapsulation negotiate
no switchport nonegotiate
no switchport protected
no switchport block multicast
no switchport block unicast
no ip arp inspection trust
ip arp inspection limit rate 15 burst interval 1
ip arp inspection limit rate 15
no shutdown
snmp trap mac-notification change added
snmp trap mac-notification change removed
snmp trap link-status
spanning-tree port-priority 3
spanning-tree cost 3
ip igmp snooping tcn flood
!
interface FastEthernet1/0/7
switchport
switchport access vlan 1
switchport trunk encapsulation negotiate
no switchport nonegotiate
no switchport protected
no switchport block multicast
no switchport block unicast
no ip arp inspection trust
ip arp inspection limit rate 15 burst interval 1
ip arp inspection limit rate 15
no shutdown
snmp trap mac-notification change added
snmp trap mac-notification change removed
snmp trap link-status
spanning-tree port-priority 3
spanning-tree cost 3
ip igmp snooping tcn flood
!
interface FastEthernet1/0/8
switchport
switchport access vlan 1
switchport trunk encapsulation negotiate
no switchport nonegotiate
no switchport protected
no switchport block multicast
no switchport block unicast
no ip arp inspection trust
ip arp inspection limit rate 15 burst interval 1
ip arp inspection limit rate 15
no shutdown
snmp trap mac-notification change added
snmp trap mac-notification change removed
snmp trap link-status
spanning-tree port-priority 3
spanning-tree cost 3
ip igmp snooping tcn flood
!
interface FastEthernet1/0/9
switchport
switchport access vlan 1
switchport trunk encapsulation negotiate
no switchport nonegotiate
no switchport protected
no switchport block multicast
no switchport block unicast
no ip arp inspection trust
ip arp inspection limit rate 15 burst interval 1
ip arp inspection limit rate 15
no shutdown
snmp trap mac-notification change added
snmp trap mac-notification change removed
snmp trap link-status
spanning-tree port-priority 3
spanning-tree cost 3
ip igmp snooping tcn flood
!
interface FastEthernet1/0/10
switchport
switchport access vlan 1
switchport trunk encapsulation negotiate
no switchport nonegotiate
no switchport protected
no switchport block multicast
no switchport block unicast
no ip arp inspection trust
ip arp inspection limit rate 15 burst interval 1
ip arp inspection limit rate 15
no shutdown
snmp trap mac-notification change added
snmp trap mac-notification change removed
snmp trap link-status
spanning-tree port-priority 3
spanning-tree cost 3
ip igmp snooping tcn flood
!
interface FastEthernet1/0/11
switchport
switchport access vlan 1
switchport trunk encapsulation negotiate
no switchport nonegotiate
no switchport protected
no switchport block multicast
no switchport block unicast
no ip arp inspection trust
ip arp inspection limit rate 15 burst interval 1
ip arp inspection limit rate 15
no shutdown
snmp trap mac-notification change added
snmp trap mac-notification change removed
snmp trap link-status
spanning-tree port-priority 3
spanning-tree cost 3
ip igmp snooping tcn flood
!
interface FastEthernet1/0/12
switchport
switchport access vlan 1
switchport trunk encapsulation negotiate
no switchport nonegotiate
no switchport protected
no switchport block multicast
no switchport block unicast
no ip arp inspection trust
ip arp inspection limit rate 15 burst interval 1
ip arp inspection limit rate 15
no shutdown
snmp trap mac-notification change added
snmp trap mac-notification change removed
snmp trap link-status
spanning-tree port-priority 3
spanning-tree cost 3
ip igmp snooping tcn flood
!
interface FastEthernet1/0/13
switchport
switchport access vlan 1
switchport trunk encapsulation negotiate
no switchport nonegotiate
no switchport protected
no switchport block multicast
no switchport block unicast
no ip arp inspection trust
ip arp inspection limit rate 15 burst interval 1
ip arp inspection limit rate 15
no shutdown
snmp trap mac-notification change added
snmp trap mac-notification change removed
snmp trap link-status
spanning-tree port-priority 3
spanning-tree cost 3
ip igmp snooping tcn flood
!
interface FastEthernet1/0/14
switchport
switchport access vlan 1
switchport trunk encapsulation negotiate
no switchport nonegotiate
no switchport protected
no switchport block multicast
no switchport block unicast
no ip arp inspection trust
ip arp inspection limit rate 15 burst interval 1
ip arp inspection limit rate 15
no shutdown
snmp trap mac-notification change added
snmp trap mac-notification change removed
snmp trap link-status
spanning-tree port-priority 3
spanning-tree cost 3
ip igmp snooping tcn flood
!
interface FastEthernet1/0/15
switchport
switchport access vlan 1
switchport trunk encapsulation negotiate
no switchport nonegotiate
no switchport protected
no switchport block multicast
no switchport block unicast
no ip arp inspection trust
ip arp inspection limit rate 15 burst interval 1
ip arp inspection limit rate 15
no shutdown
snmp trap mac-notification change added
snmp trap mac-notification change removed
snmp trap link-status
spanning-tree port-priority 3
spanning-tree cost 3
ip igmp snooping tcn flood
!
interface FastEthernet1/0/16
switchport
switchport access vlan 1
switchport trunk encapsulation negotiate
no switchport nonegotiate
no switchport protected
no switchport block multicast
no switchport block unicast
no ip arp inspection trust
ip arp inspection limit rate 15 burst interval 1
ip arp inspection limit rate 15
no shutdown
snmp trap mac-notification change added
snmp trap mac-notification change removed
snmp trap link-status
spanning-tree port-priority 3
spanning-tree cost 3
ip igmp snooping tcn flood
!
interface FastEthernet1/0/17
switchport
switchport access vlan 1
switchport trunk encapsulation negotiate
no switchport nonegotiate
no switchport protected
no switchport block multicast
no switchport block unicast
no ip arp inspection trust
ip arp inspection limit rate 15 burst interval 1
ip arp inspection limit rate 15
no shutdown
snmp trap mac-notification change added
snmp trap mac-notification change removed
snmp trap link-status
spanning-tree port-priority 3
spanning-tree cost 3
ip igmp snooping tcn flood
!
interface FastEthernet1/0/18
switchport
switchport access vlan 1
switchport trunk encapsulation negotiate
no switchport nonegotiate
no switchport protected
no switchport block multicast
no switchport block unicast
no ip arp inspection trust
ip arp inspection limit rate 15 burst interval 1
ip arp inspection limit rate 15
no shutdown
snmp trap mac-notification change added
snmp trap mac-notification change removed
snmp trap link-status
spanning-tree port-priority 3
spanning-tree cost 3
ip igmp snooping tcn flood
!
interface FastEthernet1/0/19
switchport
switchport access vlan 1
switchport trunk encapsulation negotiate
no switchport nonegotiate
no switchport protected
no switchport block multicast
no switchport block unicast
no ip arp inspection trust
ip arp inspection limit rate 15 burst interval 1
ip arp inspection limit rate 15
no shutdown
snmp trap mac-notification change added
snmp trap mac-notification change removed
snmp trap link-status
spanning-tree port-priority 3
spanning-tree cost 3
ip igmp snooping tcn flood
!
interface FastEthernet1/0/20
switchport
switchport access vlan 1
switchport trunk encapsulation negotiate
no switchport nonegotiate
no switchport protected
no switchport block multicast
no switchport block unicast
no ip arp inspection trust
ip arp inspection limit rate 15 burst interval 1
ip arp inspection limit rate 15
no shutdown
snmp trap mac-notification change added
snmp trap mac-notification change removed
snmp trap link-status
spanning-tree port-priority 3
spanning-tree cost 3
ip igmp snooping tcn flood
!
interface FastEthernet1/0/21
switchport
switchport access vlan 1
switchport trunk encapsulation negotiate
no switchport nonegotiate
no switchport protected
no switchport block multicast
no switchport block unicast
no ip arp inspection trust
ip arp inspection limit rate 15 burst interval 1
ip arp inspection limit rate 15
no shutdown
snmp trap mac-notification change added
snmp trap mac-notification change removed
snmp trap link-status
spanning-tree port-priority 3
spanning-tree cost 3
ip igmp snooping tcn flood
!
interface FastEthernet1/0/22
switchport
switchport access vlan 1
switchport trunk encapsulation negotiate
no switchport nonegotiate
no switchport protected
no switchport block multicast
no switchport block unicast
no ip arp inspection trust
ip arp inspection limit rate 15 burst interval 1
ip arp inspection limit rate 15
no shutdown
snmp trap mac-notification change added
snmp trap mac-notification change removed
snmp trap link-status
spanning-tree port-priority 3
spanning-tree cost 3
ip igmp snooping tcn flood
!
interface FastEthernet1/0/23
switchport
switchport access vlan 1
switchport trunk encapsulation negotiate
no switchport nonegotiate
no switchport protected
no switchport block multicast
no switchport block unicast
no ip arp inspection trust
ip arp inspection limit rate 15 burst interval 1
ip arp inspection limit rate 15
no shutdown
snmp trap mac-notification change added
snmp trap mac-notification change removed
snmp trap link-status
spanning-tree port-priority 3
spanning-tree cost 3
ip igmp snooping tcn flood
!
interface FastEthernet1/0/24
switchport
switchport access vlan 1
switchport trunk encapsulation negotiate
no switchport nonegotiate
no switchport protected
no switchport block multicast
no switchport block unicast
no ip arp inspection trust
ip arp inspection limit rate 15 burst interval 1
ip arp inspection limit rate 15
no shutdown
snmp trap mac-notification change added
snmp trap mac-notification change removed
snmp trap link-status
spanning-tree port-priority 3
spanning-tree cost 3
ip igmp snooping tcn flood
!
interface GigabitEthernet1/0/1
switchport
switchport access vlan 1
switchport trunk encapsulation negotiate
no switchport nonegotiate
no switchport protected
no switchport block multicast
no switchport block unicast
no ip arp inspection trust
ip arp inspection limit rate 15 burst interval 1
ip arp inspection limit rate 15
no shutdown
snmp trap mac-notification change added
snmp trap mac-notification change removed
snmp trap link-status
spanning-tree port-priority 3
spanning-tree cost 3
ip igmp snooping tcn flood
!
interface GigabitEthernet1/0/2
switchport
switchport access vlan 1
switchport trunk encapsulation negotiate
no switchport nonegotiate
no switchport protected
no switchport block multicast
no switchport block unicast
no ip arp inspection trust
ip arp inspection limit rate 15 burst interval 1
ip arp inspection limit rate 15
no shutdown
snmp trap mac-notification change added
snmp trap mac-notification change removed
snmp trap link-status
spanning-tree port-priority 3
spanning-tree cost 3
ip igmp snooping tcn flood
!
interface Vlan1
no ip address
shutdown
snmp trap link-status
spanning-tree port-priority 3
spanning-tree cost 3
!
ip classless
ip http server
ip http port 80
ip http authentication enable
ip http secure-server
ip http secure-port 443
ip http secure-active-session-modules all
ip http max-connections 16
ip http timeout-policy idle 180 life 180 requests 25
ip http active-session-modules all
ip http client cache memory pool 100
ip http client cache memory file 2
ip http client cache ager interval 5
ip http client connection timeout 10
ip http client connection retry 1
ip http client connection idle timeout 30
ip http client response timeout 30
!
!
no ip sla logging traps
ip sla enable reaction-alerts
logging history size 1
logging history warnings
logging trap informational
logging delimiter tcp
logging facility local7
no logging source-interface
cdp run
!
snmp-server inform retries 3 timeout 15 pending 25
snmp mib notification-log globalsize 500
snmp mib notification-log globalageout 15
!
alias exec h help
alias exec lo logout
alias exec p ping
alias exec r resume
alias exec s show
alias exec u undebug
alias exec un undebug
alias exec w where
default-value exec-character-bits 7
default-value special-character-bits 7
default-value data-character-bits 8
!
line con 0
line vty 5 15
!
cns id hostname
cns id hostname event
cns id hostname image
cns image retry 60
mac address-table notification change interval 1
mac address-table notification change history-size 1
mac address-table notification change
mac address-table aging-time 300
netconf max-sessions 4
netconf lock-time 10
event manager scheduler script thread class default number 1
event manager scheduler applet thread class default number 32
event manager scheduler shell thread class default number 1
event manager scheduler shell thread class Z number 1
event manager history size events 10
event manager history size traps 10
end