Cisco Catalyst 3750 初回電源投入後の基本設定

シェアする

初めて電源投入した後に、基本的な部分として初期設定をします。

とりあえず、最低限のセキュリティーの設定をし、リモート接続ができるようになれば、いいと思います。

デフォルトも含めた設定情報

電源投入後のデフォルトも含めた設定情報です。バージョンは、12.2(55)SE12です。

Switch>enable
Switch#show running-config all
Building configuration...

Current configuration with default configurations exposed : 23948 bytes
!
version 12.2
parser cache
no service log backtrace
no service config
no service exec-callback
no service nagle
service slave-log
no service slave-coredump
no service pad to-xot
no service pad from-xot
no service pad cmns
no service pad
no service telnet-zeroidle
no service tcp-keepalives-in
no service tcp-keepalives-out
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
no service exec-wait
no service linenumber
no service internal
no service scripting
no service compress-config
service prompt config
no service old-slip-prompts
no service pt-vty-logging
no service disable-ip-fast-frag
no service sequence-numbers
service counters max age 0
!
hostname Switch
!
boot-start-marker
boot-end-marker
!
shell processing
no logging discriminator
logging exception 4096
no logging count
no logging message-counter log
no logging message-counter debug
logging message-counter syslog
no logging snmp-authfail
logging buginf
logging queue-limit 100
logging queue-limit esm 0
logging queue-limit trap 100
logging buffered 4096 debugging
logging reload message-limit 1000 notifications
logging console debugging
logging monitor debugging
logging on
!
!
!
no aaa new-model
switch 1 provision ws-c3750v2-24ts
system mtu routing 1500
power xps 1 name
power xps 1 port 1 name
power xps 1 port 2 name
power xps 1 port 3 name
power xps 1 port 4 name
power xps 1 port 5 name
power xps 1 port 6 name
power xps 1 port 7 name
power xps 1 port 8 name
power xps 1 port 9 name
power xps 2 name
power xps 2 port 1 name
power xps 2 port 2 name
power xps 2 port 3 name
power xps 2 port 4 name
power xps 2 port 5 name
power xps 2 port 6 name
power xps 2 port 7 name
power xps 2 port 8 name
power xps 2 port 9 name
power xps 3 name
power xps 3 port 1 name
power xps 3 port 2 name
power xps 3 port 3 name
power xps 3 port 4 name
power xps 3 port 5 name
power xps 3 port 6 name
power xps 3 port 7 name
power xps 3 port 8 name
power xps 3 port 9 name
power xps 4 name
power xps 4 port 1 name
power xps 4 port 2 name
power xps 4 port 3 name
power xps 4 port 4 name
power xps 4 port 5 name
power xps 4 port 6 name
power xps 4 port 7 name
power xps 4 port 8 name
power xps 4 port 9 name
power xps 5 name
power xps 5 port 1 name
power xps 5 port 2 name
power xps 5 port 3 name
power xps 5 port 4 name
power xps 5 port 5 name
power xps 5 port 6 name
power xps 5 port 7 name
power xps 5 port 8 name
power xps 5 port 9 name
power xps 6 name
power xps 6 port 1 name
power xps 6 port 2 name
power xps 6 port 3 name
power xps 6 port 4 name
power xps 6 port 5 name
power xps 6 port 6 name
power xps 6 port 7 name
power xps 6 port 8 name
power xps 6 port 9 name
power xps 7 name
power xps 7 port 1 name
power xps 7 port 2 name
power xps 7 port 3 name
power xps 7 port 4 name
power xps 7 port 5 name
power xps 7 port 6 name
power xps 7 port 7 name
power xps 7 port 8 name
power xps 7 port 9 name
power xps 8 name
power xps 8 port 1 name
power xps 8 port 2 name
power xps 8 port 3 name
power xps 8 port 4 name
power xps 8 port 5 name
power xps 8 port 6 name
power xps 8 port 7 name
power xps 8 port 8 name
power xps 8 port 9 name
power xps 9 name
power xps 9 port 1 name
power xps 9 port 2 name
power xps 9 port 3 name
power xps 9 port 4 name
power xps 9 port 5 name
power xps 9 port 6 name
power xps 9 port 7 name
power xps 9 port 8 name
power xps 9 port 9 name
no cisp enable
authentication mac-move deny
authentication logging verbose
authentication command bounce-port ignore
authentication command disable-port ignore
authentication critical recovery delay 100
no mab request format attribute 32
mab logging verbose
nmsp notification interval attachment 30
nmsp notification interval location 30
ip subnet-zero
ip sticky-arp
!
!
no ip dhcp snooping information option allow-untrusted
ip dhcp snooping information option
no ip dhcp snooping database
ip dhcp snooping database write-delay 300
ip dhcp snooping database timeout 300
ip dhcp snooping verify mac-address
ip dhcp snooping verify no-relay-agent-address
ip device tracking probe count 3
ip device tracking probe interval 30
ip device tracking probe use-svi
ip device tracking probe delay 0
no ip device tracking
ip arp inspection log-buffer entries 32
ip arp inspection log-buffer logs 5 interval 1
ip igmp snooping report-suppression
no ip igmp snooping tcn query solicit
ip igmp snooping tcn flood query count 2
ip igmp snooping robustness-variable 2
ip igmp snooping last-member-query-count 2
ip igmp snooping last-member-query-interval 1000
ip igmp snooping querier version 2
ip igmp snooping querier query-interval 60
ip igmp snooping querier max-response-time 10
ip igmp snooping querier timer expiry 0
ip igmp snooping querier tcn query count 2
ip igmp snooping querier tcn query interval 10
no ip igmp snooping querier
ip igmp snooping vlan 1
ip igmp snooping vlan 1 mrouter learn pim-dvmrp
no ip igmp snooping vlan 1 immediate-leave
ip igmp snooping vlan 1 robustness-variable 0
ip igmp snooping vlan 1 last-member-query-count 0
ip igmp snooping vlan 1 last-member-query-interval 0
ip igmp snooping
 cluster run
!
vmps reconfirm 60
vmps retry 3
mls qos rewrite ip dscp
mvr vlan 1
mvr querytime 5
mvr mode compatible
no cts sxp enable
cts sxp retry period 120
cts sxp reconciliation period 120
setup express
!
scripting tcl low-memory 9848448
!
!
power inline consumption default 15400
dot1x system-auth-control
dot1x logging verbose
dot1x supplicant force-multicast
dot1x supplicant controlled transient
no dot1x critical eapol
location prefer static weight 0
location prefer lldp-med weight 2
location prefer cdp weight 1
!
!
!
port-channel load-balance src-mac
spanning-tree mode pvst
no spanning-tree dispute
spanning-tree transmit hold-count 6
spanning-tree optimize bpdu transmission
spanning-tree queue maxsize 12288
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
spanning-tree uplinkfast max-update-rate 90863424
spanning-tree pathcost method short
!
!
vlan internal allocation policy ascending
!
!
!
!
interface FastEthernet1/0/1
 switchport
 switchport access vlan 1
 switchport trunk encapsulation negotiate
 no switchport nonegotiate
 no switchport protected
 no switchport block multicast
 no switchport block unicast
 no ip arp inspection trust
 ip arp inspection limit rate 15 burst interval 1
 ip arp inspection limit rate 15
 no shutdown
 mls qos cos 0
 snmp trap mac-notification change added
 snmp trap mac-notification change removed
 snmp trap link-status
 cdp tlv location
 cdp tlv server-location
 cdp tlv app
 spanning-tree port-priority 3
 spanning-tree cost 3
 ip igmp snooping tcn flood
!
interface FastEthernet1/0/2
 switchport
 switchport access vlan 1
 switchport trunk encapsulation negotiate
 no switchport nonegotiate
 no switchport protected
 no switchport block multicast
 no switchport block unicast
 no ip arp inspection trust
 ip arp inspection limit rate 15 burst interval 1
 ip arp inspection limit rate 15
 no shutdown
 mls qos cos 0
 snmp trap mac-notification change added
 snmp trap mac-notification change removed
 snmp trap link-status
 cdp tlv location
 cdp tlv server-location
 cdp tlv app
 spanning-tree port-priority 3
 spanning-tree cost 3
 ip igmp snooping tcn flood
!
interface FastEthernet1/0/3
 switchport
 switchport access vlan 1
 switchport trunk encapsulation negotiate
 no switchport nonegotiate
 no switchport protected
 no switchport block multicast
 no switchport block unicast
 no ip arp inspection trust
 ip arp inspection limit rate 15 burst interval 1
 ip arp inspection limit rate 15
 no shutdown
 mls qos cos 0
 snmp trap mac-notification change added
 snmp trap mac-notification change removed
 snmp trap link-status
 cdp tlv location
 cdp tlv server-location
 cdp tlv app
 spanning-tree port-priority 3
 spanning-tree cost 3
 ip igmp snooping tcn flood
!
interface FastEthernet1/0/4
 switchport
 switchport access vlan 1
 switchport trunk encapsulation negotiate
 no switchport nonegotiate
 no switchport protected
 no switchport block multicast
 no switchport block unicast
 no ip arp inspection trust
 ip arp inspection limit rate 15 burst interval 1
 ip arp inspection limit rate 15
 no shutdown
 mls qos cos 0
 snmp trap mac-notification change added
 snmp trap mac-notification change removed
 snmp trap link-status
 cdp tlv location
 cdp tlv server-location
 cdp tlv app
 spanning-tree port-priority 3
 spanning-tree cost 3
 ip igmp snooping tcn flood
!
interface FastEthernet1/0/5
 switchport
 switchport access vlan 1
 switchport trunk encapsulation negotiate
 no switchport nonegotiate
 no switchport protected
 no switchport block multicast
 no switchport block unicast
 no ip arp inspection trust
 ip arp inspection limit rate 15 burst interval 1
 ip arp inspection limit rate 15
 no shutdown
 mls qos cos 0
 snmp trap mac-notification change added
 snmp trap mac-notification change removed
 snmp trap link-status
 cdp tlv location
 cdp tlv server-location
 cdp tlv app
 spanning-tree port-priority 3
 spanning-tree cost 3
 ip igmp snooping tcn flood
!
interface FastEthernet1/0/6
 switchport
 switchport access vlan 1
 switchport trunk encapsulation negotiate
 no switchport nonegotiate
 no switchport protected
 no switchport block multicast
 no switchport block unicast
 no ip arp inspection trust
 ip arp inspection limit rate 15 burst interval 1
 ip arp inspection limit rate 15
 no shutdown
 mls qos cos 0
 snmp trap mac-notification change added
 snmp trap mac-notification change removed
 snmp trap link-status
 cdp tlv location
 cdp tlv server-location
 cdp tlv app
 spanning-tree port-priority 3
 spanning-tree cost 3
 ip igmp snooping tcn flood
!
interface FastEthernet1/0/7
 switchport
 switchport access vlan 1
 switchport trunk encapsulation negotiate
 no switchport nonegotiate
 no switchport protected
 no switchport block multicast
 no switchport block unicast
 no ip arp inspection trust
 ip arp inspection limit rate 15 burst interval 1
 ip arp inspection limit rate 15
 no shutdown
 mls qos cos 0
 snmp trap mac-notification change added
 snmp trap mac-notification change removed
 snmp trap link-status
 cdp tlv location
 cdp tlv server-location
 cdp tlv app
 spanning-tree port-priority 3
 spanning-tree cost 3
 ip igmp snooping tcn flood
!
interface FastEthernet1/0/8
 switchport
 switchport access vlan 1
 switchport trunk encapsulation negotiate
 no switchport nonegotiate
 no switchport protected
 no switchport block multicast
 no switchport block unicast
 no ip arp inspection trust
 ip arp inspection limit rate 15 burst interval 1
 ip arp inspection limit rate 15
 no shutdown
 mls qos cos 0
 snmp trap mac-notification change added
 snmp trap mac-notification change removed
 snmp trap link-status
 cdp tlv location
 cdp tlv server-location
 cdp tlv app
 spanning-tree port-priority 3
 spanning-tree cost 3
 ip igmp snooping tcn flood
!
interface FastEthernet1/0/9
 switchport
 switchport access vlan 1
 switchport trunk encapsulation negotiate
 no switchport nonegotiate
 no switchport protected
 no switchport block multicast
 no switchport block unicast
 no ip arp inspection trust
 ip arp inspection limit rate 15 burst interval 1
 ip arp inspection limit rate 15
 no shutdown
 mls qos cos 0
 snmp trap mac-notification change added
 snmp trap mac-notification change removed
 snmp trap link-status
 cdp tlv location
 cdp tlv server-location
 cdp tlv app
 spanning-tree port-priority 3
 spanning-tree cost 3
 ip igmp snooping tcn flood
!
interface FastEthernet1/0/10
 switchport
 switchport access vlan 1
 switchport trunk encapsulation negotiate
 no switchport nonegotiate
 no switchport protected
 no switchport block multicast
 no switchport block unicast
 no ip arp inspection trust
 ip arp inspection limit rate 15 burst interval 1
 ip arp inspection limit rate 15
 no shutdown
 mls qos cos 0
 snmp trap mac-notification change added
 snmp trap mac-notification change removed
 snmp trap link-status
 cdp tlv location
 cdp tlv server-location
 cdp tlv app
 spanning-tree port-priority 3
 spanning-tree cost 3
 ip igmp snooping tcn flood
!
interface FastEthernet1/0/11
 switchport
 switchport access vlan 1
 switchport trunk encapsulation negotiate
 no switchport nonegotiate
 no switchport protected
 no switchport block multicast
 no switchport block unicast
 no ip arp inspection trust
 ip arp inspection limit rate 15 burst interval 1
 ip arp inspection limit rate 15
 no shutdown
 mls qos cos 0
 snmp trap mac-notification change added
 snmp trap mac-notification change removed
 snmp trap link-status
 cdp tlv location
 cdp tlv server-location
 cdp tlv app
 spanning-tree port-priority 3
 spanning-tree cost 3
 ip igmp snooping tcn flood
!
interface FastEthernet1/0/12
 switchport
 switchport access vlan 1
 switchport trunk encapsulation negotiate
 no switchport nonegotiate
 no switchport protected
 no switchport block multicast
 no switchport block unicast
 no ip arp inspection trust
 ip arp inspection limit rate 15 burst interval 1
 ip arp inspection limit rate 15
 no shutdown
 mls qos cos 0
 snmp trap mac-notification change added
 snmp trap mac-notification change removed
 snmp trap link-status
 cdp tlv location
 cdp tlv server-location
 cdp tlv app
 spanning-tree port-priority 3
 spanning-tree cost 3
 ip igmp snooping tcn flood
!
interface FastEthernet1/0/13
 switchport
 switchport access vlan 1
 switchport trunk encapsulation negotiate
 no switchport nonegotiate
 no switchport protected
 no switchport block multicast
 no switchport block unicast
 no ip arp inspection trust
 ip arp inspection limit rate 15 burst interval 1
 ip arp inspection limit rate 15
 no shutdown
 mls qos cos 0
 snmp trap mac-notification change added
 snmp trap mac-notification change removed
 snmp trap link-status
 cdp tlv location
 cdp tlv server-location
 cdp tlv app
 spanning-tree port-priority 3
 spanning-tree cost 3
 ip igmp snooping tcn flood
!
interface FastEthernet1/0/14
 switchport
 switchport access vlan 1
 switchport trunk encapsulation negotiate
 no switchport nonegotiate
 no switchport protected
 no switchport block multicast
 no switchport block unicast
 no ip arp inspection trust
 ip arp inspection limit rate 15 burst interval 1
 ip arp inspection limit rate 15
 no shutdown
 mls qos cos 0
 snmp trap mac-notification change added
 snmp trap mac-notification change removed
 snmp trap link-status
 cdp tlv location
 cdp tlv server-location
 cdp tlv app
 spanning-tree port-priority 3
 spanning-tree cost 3
 ip igmp snooping tcn flood
!
interface FastEthernet1/0/15
 switchport
 switchport access vlan 1
 switchport trunk encapsulation negotiate
 no switchport nonegotiate
 no switchport protected
 no switchport block multicast
 no switchport block unicast
 no ip arp inspection trust
 ip arp inspection limit rate 15 burst interval 1
 ip arp inspection limit rate 15
 no shutdown
 mls qos cos 0
 snmp trap mac-notification change added
 snmp trap mac-notification change removed
 snmp trap link-status
 cdp tlv location
 cdp tlv server-location
 cdp tlv app
 spanning-tree port-priority 3
 spanning-tree cost 3
 ip igmp snooping tcn flood
!
interface FastEthernet1/0/16
 switchport
 switchport access vlan 1
 switchport trunk encapsulation negotiate
 no switchport nonegotiate
 no switchport protected
 no switchport block multicast
 no switchport block unicast
 no ip arp inspection trust
 ip arp inspection limit rate 15 burst interval 1
 ip arp inspection limit rate 15
 no shutdown
 mls qos cos 0
 snmp trap mac-notification change added
 snmp trap mac-notification change removed
 snmp trap link-status
 cdp tlv location
 cdp tlv server-location
 cdp tlv app
 spanning-tree port-priority 3
 spanning-tree cost 3
 ip igmp snooping tcn flood
!
interface FastEthernet1/0/17
 switchport
 switchport access vlan 1
 switchport trunk encapsulation negotiate
 no switchport nonegotiate
 no switchport protected
 no switchport block multicast
 no switchport block unicast
 no ip arp inspection trust
 ip arp inspection limit rate 15 burst interval 1
 ip arp inspection limit rate 15
 no shutdown
 mls qos cos 0
 snmp trap mac-notification change added
 snmp trap mac-notification change removed
 snmp trap link-status
 cdp tlv location
 cdp tlv server-location
 cdp tlv app
 spanning-tree port-priority 3
 spanning-tree cost 3
 ip igmp snooping tcn flood
!
interface FastEthernet1/0/18
 switchport
 switchport access vlan 1
 switchport trunk encapsulation negotiate
 no switchport nonegotiate
 no switchport protected
 no switchport block multicast
 no switchport block unicast
 no ip arp inspection trust
 ip arp inspection limit rate 15 burst interval 1
 ip arp inspection limit rate 15
 no shutdown
 mls qos cos 0
 snmp trap mac-notification change added
 snmp trap mac-notification change removed
 snmp trap link-status
 cdp tlv location
 cdp tlv server-location
 cdp tlv app
 spanning-tree port-priority 3
 spanning-tree cost 3
 ip igmp snooping tcn flood
!
interface FastEthernet1/0/19
 switchport
 switchport access vlan 1
 switchport trunk encapsulation negotiate
 no switchport nonegotiate
 no switchport protected
 no switchport block multicast
 no switchport block unicast
 no ip arp inspection trust
 ip arp inspection limit rate 15 burst interval 1
 ip arp inspection limit rate 15
 no shutdown
 mls qos cos 0
 snmp trap mac-notification change added
 snmp trap mac-notification change removed
 snmp trap link-status
 cdp tlv location
 cdp tlv server-location
 cdp tlv app
 spanning-tree port-priority 3
 spanning-tree cost 3
 ip igmp snooping tcn flood
!
interface FastEthernet1/0/20
 switchport
 switchport access vlan 1
 switchport trunk encapsulation negotiate
 no switchport nonegotiate
 no switchport protected
 no switchport block multicast
 no switchport block unicast
 no ip arp inspection trust
 ip arp inspection limit rate 15 burst interval 1
 ip arp inspection limit rate 15
 no shutdown
 mls qos cos 0
 snmp trap mac-notification change added
 snmp trap mac-notification change removed
 snmp trap link-status
 cdp tlv location
 cdp tlv server-location
 cdp tlv app
 spanning-tree port-priority 3
 spanning-tree cost 3
 ip igmp snooping tcn flood
!
interface FastEthernet1/0/21
 switchport
 switchport access vlan 1
 switchport trunk encapsulation negotiate
 no switchport nonegotiate
 no switchport protected
 no switchport block multicast
 no switchport block unicast
 no ip arp inspection trust
 ip arp inspection limit rate 15 burst interval 1
 ip arp inspection limit rate 15
 no shutdown
 mls qos cos 0
 snmp trap mac-notification change added
 snmp trap mac-notification change removed
 snmp trap link-status
 cdp tlv location
 cdp tlv server-location
 cdp tlv app
 spanning-tree port-priority 3
 spanning-tree cost 3
 ip igmp snooping tcn flood
!
interface FastEthernet1/0/22
 switchport
 switchport access vlan 1
 switchport trunk encapsulation negotiate
 no switchport nonegotiate
 no switchport protected
 no switchport block multicast
 no switchport block unicast
 no ip arp inspection trust
 ip arp inspection limit rate 15 burst interval 1
 ip arp inspection limit rate 15
 no shutdown
 mls qos cos 0
 snmp trap mac-notification change added
 snmp trap mac-notification change removed
 snmp trap link-status
 cdp tlv location
 cdp tlv server-location
 cdp tlv app
 spanning-tree port-priority 3
 spanning-tree cost 3
 ip igmp snooping tcn flood
!
interface FastEthernet1/0/23
 switchport
 switchport access vlan 1
 switchport trunk encapsulation negotiate
 no switchport nonegotiate
 no switchport protected
 no switchport block multicast
 no switchport block unicast
 no ip arp inspection trust
 ip arp inspection limit rate 15 burst interval 1
 ip arp inspection limit rate 15
 no shutdown
 mls qos cos 0
 snmp trap mac-notification change added
 snmp trap mac-notification change removed
 snmp trap link-status
 cdp tlv location
 cdp tlv server-location
 cdp tlv app
 spanning-tree port-priority 3
 spanning-tree cost 3
 ip igmp snooping tcn flood
!
interface FastEthernet1/0/24
 switchport
 switchport access vlan 1
 switchport trunk encapsulation negotiate
 no switchport nonegotiate
 no switchport protected
 no switchport block multicast
 no switchport block unicast
 no ip arp inspection trust
 ip arp inspection limit rate 15 burst interval 1
 ip arp inspection limit rate 15
 no shutdown
 mls qos cos 0
 snmp trap mac-notification change added
 snmp trap mac-notification change removed
 snmp trap link-status
 cdp tlv location
 cdp tlv server-location
 cdp tlv app
 spanning-tree port-priority 3
 spanning-tree cost 3
 ip igmp snooping tcn flood
!
interface GigabitEthernet1/0/1
 switchport
 switchport access vlan 1
 switchport trunk encapsulation negotiate
 no switchport nonegotiate
 no switchport protected
 no switchport block multicast
 no switchport block unicast
 no ip arp inspection trust
 ip arp inspection limit rate 15 burst interval 1
 ip arp inspection limit rate 15
 no shutdown
 mls qos cos 0
 snmp trap mac-notification change added
 snmp trap mac-notification change removed
 snmp trap link-status
 cdp tlv location
 cdp tlv server-location
 cdp tlv app
 spanning-tree port-priority 3
 spanning-tree cost 3
 ip igmp snooping tcn flood
!
interface GigabitEthernet1/0/2
 switchport
 switchport access vlan 1
 switchport trunk encapsulation negotiate
 no switchport nonegotiate
 no switchport protected
 no switchport block multicast
 no switchport block unicast
 no ip arp inspection trust
 ip arp inspection limit rate 15 burst interval 1
 ip arp inspection limit rate 15
 no shutdown
 mls qos cos 0
 snmp trap mac-notification change added
 snmp trap mac-notification change removed
 snmp trap link-status
 cdp tlv location
 cdp tlv server-location
 cdp tlv app
 spanning-tree port-priority 3
 spanning-tree cost 3
 ip igmp snooping tcn flood
!
interface Vlan1
 no ip address
 no shutdown
 snmp trap link-status
 spanning-tree port-priority 3
 spanning-tree cost 3
!
ip classless
ip http server
ip http port 80
ip http authentication enable
ip http secure-server
ip http secure-port 443
ip http secure-active-session-modules all
ip http max-connections 16
ip http timeout-policy idle 180 life 180 requests 25
ip http active-session-modules all
ip http client cache memory pool 100
ip http client cache memory file 2
ip http client cache ager interval 5
ip http client connection timeout 10
ip http client connection retry 1
ip http client connection idle timeout 30
ip http client response timeout 30
ip http path flash:/c3750-ipservicesk9-mz.122-55.SE12/html
!
!
no ip sla logging traps

logging history size 1
logging history warnings
logging trap informational
logging delimiter tcp
no logging origin-id
logging facility local7
no logging source-interface
cdp run
cdp tlv location
cdp tlv app
!
snmp-server inform retries 3 timeout 15 pending 25
snmp mib notification-log globalsize 500
snmp mib notification-log globalageout 15
!
vstack join-window mode auto
vstack
alias exec h help
alias exec lo logout
alias exec p ping
alias exec r resume
alias exec s show
alias exec u undebug
alias exec un undebug
alias exec w where
default-value exec-character-bits 7
default-value special-character-bits 7
default-value data-character-bits 8
!
line con 0
 no media-type rj45
line vty 0 4
 login
line vty 5 15
 login
!
cns id hostname
cns id hostname event
cns id hostname image
cns image retry 60
mac address-table notification change interval 1
mac address-table notification change history-size 1
mac address-table notification change
mac address-table aging-time 300
netconf max-sessions 4
netconf lock-time 10
event manager scheduler script thread class default number 1
event manager scheduler applet thread class default number 32
event manager scheduler shell thread class default number 1
event manager scheduler shell thread class Z number 1
event manager history size events 10
event manager history size traps 10
end

初期基本設定

電源投入後の基本設定したものです。

必要でない機能の無効化
Switch(config)#ip dhcp bootp ignore
Switch(config)#no service dhcp
Switch(config)#no ip domain-lookup
Switch(config)#no ip http server
Switch(config)#no ip http secure-server
Switch(config)#no cdp run
Switch(config)#no lldp run
Switch(config)#no vstack
IPアドレスとデフォルトゲートウェイの設定
Switch(config)#interface vlan 1
Switch(config-if)#ip address 192.168.1.231 255.255.255.0
Switch(config-if)#exit
Switch(config)#ip default-gateway 192.168.1.1
Switch(config)#exit
パスワードの設定
Switch(config)#username admin secret xxxx
Switch(config)#line console 0
Switch(config-line)#login local
Switch(config-line)#exit
Switch(config)#enable secret xxxx
Switch(config)#line vty 0 15
Switch(config-line)#login local
Switch(config-line)#exit
SSHの鍵生成
Switch(config)#hostname SW1
SW1(config)#ip domain-name orangetakam.local
SW1(config)#crypto key generate rsa
The name for the keys will be: SW1.orangetakam.local
Choose the size of the key modulus in the range of 360 to 2048 for your
  General Purpose Keys. Choosing a key modulus greater than 512 may take
  a few minutes.

How many bits in the modulus [512]: 2048
% Generating 2048 bit RSA keys, keys will be non-exportable...[OK]

SW1(config)#ip ssh version 2

設定後の定義状態

ひととおり、設定した後の定義です。

SW1#show running-config
Building configuration...

Current configuration : 1715 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
no service dhcp
!
hostname R1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$YC1D$UQZLX..oBloEb3E8HzuHT.
!
username tkadmin secret 5 $1$01ua$6BsQMAajsYHRsyGo41uT.0
!
!
no aaa new-model
switch 1 provision ws-c3750v2-24ts
system mtu routing 1500
no ip domain-lookup
ip domain-name orangetakam.local
ip dhcp bootp ignore
!
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
ip ssh version 2
!
!
!
interface FastEthernet1/0/1
!
interface FastEthernet1/0/2
!
interface FastEthernet1/0/3
!
interface FastEthernet1/0/4
!
interface FastEthernet1/0/5
!
interface FastEthernet1/0/6
!
interface FastEthernet1/0/7
!
interface FastEthernet1/0/8
!
interface FastEthernet1/0/9
!
interface FastEthernet1/0/10
!
interface FastEthernet1/0/11
!
interface FastEthernet1/0/12
!
interface FastEthernet1/0/13
!
interface FastEthernet1/0/14
!
interface FastEthernet1/0/15
!
interface FastEthernet1/0/16
!
interface FastEthernet1/0/17
!
interface FastEthernet1/0/18
!
interface FastEthernet1/0/19
!
interface FastEthernet1/0/20
!
interface FastEthernet1/0/21
!
interface FastEthernet1/0/22
!
interface FastEthernet1/0/23
!
interface FastEthernet1/0/24
!
interface GigabitEthernet1/0/1
!
interface GigabitEthernet1/0/2
!
interface Vlan1
 ip address 192.168.1.231 255.255.255.0
!
ip default-gateway 192.168.1.1
ip classless
no ip http server
no ip http secure-server
!
!
no cdp run
!
!
no vstack
!
line con 0
 login local
line vty 0 4
 login local
line vty 5 15
 login local
!
end