Cisco Catalyst 3750 VLANの作成(アクセスポート)

シェアする

Catalystであれば、どこのネットワークでも当たり前のように、VLANの設定がされているかと思います。Catalystであれば、直接インターフェースにIPアドレスを割り当てず、VLANを作成して、物理ポートに作成したVLANを割り当てて、VLANにIPアドレスを割り当てます。

初期の状態

Catalystでは、デフォルトで、VLAN1が用意されており、全ての物理ポートにVLAN1が割り当てられています。

VLANで使用できるのは、「1-4096」の範囲で、「1002-1024」はCiscoで予約されたVLANのため、使用することはできません。また、初期状態で存在するVLAN1を削除する事もできません。

SW1#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/0/1, Fa1/0/2, Fa1/0/3
                                                Fa1/0/4, Fa1/0/5, Fa1/0/6
                                                Fa1/0/7, Fa1/0/8, Fa1/0/9
                                                Fa1/0/10, Fa1/0/11, Fa1/0/12
                                                Fa1/0/13, Fa1/0/14, Fa1/0/15
                                                Fa1/0/16, Fa1/0/17, Fa1/0/18
                                                Fa1/0/19, Fa1/0/20, Fa1/0/21
                                                Fa1/0/22, Fa1/0/23, Fa1/0/24
                                                Gi1/0/1, Gi1/0/2
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0
1003 tr    101003     1500  -      -      -        -    -        0      0
1004 fdnet 101004     1500  -      -      -        ieee -        0      0
1005 trnet 101005     1500  -      -      -        ibm  -        0      0

Remote SPAN VLANs
------------------------------------------------------------------------------


Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------

VLANの作成

単純なL2スイッチ用途の使用であれば、そのまま使用することが可能ですが、単一の機器でネットワークを分割したい場合は、VLANを作成します。

SW1(config)#vlan 11
SW1(config-vlan)#exit
SW1(config)#exit
SW1#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/0/1, Fa1/0/2, Fa1/0/3
                                                Fa1/0/4, Fa1/0/5, Fa1/0/6
                                                Fa1/0/7, Fa1/0/8, Fa1/0/9
                                                Fa1/0/10, Fa1/0/11, Fa1/0/12
                                                Fa1/0/13, Fa1/0/14, Fa1/0/15
                                                Fa1/0/16, Fa1/0/17, Fa1/0/18
                                                Fa1/0/19, Fa1/0/20, Fa1/0/21
                                                Fa1/0/22, Fa1/0/23, Fa1/0/24
                                                Gi1/0/1, Gi1/0/2
11   VLAN0011                         active  <= VLAN 11が作成されました。
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
11   enet  100011     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0
1003 tr    101003     1500  -      -      -        -    -        0      0
1004 fdnet 101004     1500  -      -      -        ieee -        0      0
1005 trnet 101005     1500  -      -      -        ibm  -        0      0

Remote SPAN VLANs
------------------------------------------------------------------------------


Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------

物理ポートへ作成したVLANの割り当て

初期の状態では、全ての物理ポートにVLAN1を割り当てていますので、厳密には、対象の物理ポートをVLAN1からの変更になります。

SW1(config)#interface fa1/0/13
SW1(config-vlan)#switchport access vlan 11
SW1(config-vlan)#exit
SW1(config)#exit
SW1#show vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa1/0/1, Fa1/0/2, Fa1/0/3
                                                Fa1/0/4, Fa1/0/5, Fa1/0/6
                                                Fa1/0/7, Fa1/0/8, Fa1/0/9
                                                Fa1/0/10, Fa1/0/11, Fa1/0/12
                                                Fa1/0/14, Fa1/0/15, Fa1/0/16
                                                Fa1/0/17, Fa1/0/18, Fa1/0/19
                                                Fa1/0/20, Fa1/0/21, Fa1/0/22
                                                Fa1/0/23, Fa1/0/24, Gi1/0/1
                                                Gi1/0/2
11   VLAN0011                         active Fa1/0/13
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

VLAN Type  SAID       MTU   Parent RingNo BridgeNo Stp  BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1    enet  100001     1500  -      -      -        -    -        0      0
11   enet  100011     1500  -      -      -        -    -        0      0
1002 fddi  101002     1500  -      -      -        -    -        0      0
1003 tr    101003     1500  -      -      -        -    -        0      0
1004 fdnet 101004     1500  -      -      -        ieee -        0      0
1005 trnet 101005     1500  -      -      -        ibm  -        0      0

Remote SPAN VLANs
------------------------------------------------------------------------------


Primary Secondary Type              Ports
------- --------- ----------------- ------------------------------------------

SW1#show running-config interface fa1/0/13
Building configuration...

Current configuration : 63 bytes
!
interface FastEthernet1/0/13
 switchport access vlan 11
end

作成したVLANへIPアドレスの割り当て

VLANにIPアドレスを割り振ります。これで、「192.168.11.0/24」のネットワークができました。

SW1(config)#interface vlan 11
SW1(config-if)#ip address 192.168.11.11 255.255.255.0
SW1(config-if)#exit
SW1(config)#exit
SW1#show running-config interface vlan 11
Building configuration...

Current configuration : 64 bytes
!
interface vlan11
 ip address 192.168.11.11 255.255.255.0
end

VLANの削除

作成したVLANを削除してみます。基本的には、作成した時の逆の手順で行ないます。

※ 「show vlan」コマンドは省いていますが、都度、確認して下さい。

SW1(config)#interface fa1/0/13
SW1(config-if)#no switchport access vlan 11
SW1(config-if)#exit
SW1(config)#no vlan 11
SW1(config)#exit